Announcement

Collapse
No announcement yet.

Anyone running a new Elite Ti unit w/ Totalscan?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Anyone running a new Elite Ti unit w/ Totalscan?

    I am having a terrible time finding the sweet spot with this Totalscan transducer. Unit works great until I get my boat on plane then I lose bottom, no sonar/no depth. I have it mounted on a 14 Tracker ProTeam, right side of the motor, inside the first strake, per the manual. I have also tried it on the left side of the motor. I've gotten a little luck by angling the ducer downward but still cant keep bottom past 20mph. Does clean water exist on the bottom of a Tracker?

    I called Lowrance and they were not helpful. told me to install per the manual or but one of the LSS transducers (if there is something wrong with the TotalScan). Basspro said I am outside of the 60 day "no questions asked" return poicy and I'll have to deal with Lowrance.

    Unit was installed at a marina (twice) and I'm making the adjustments on my own now.

  • #2
    I installed the totalscan on my tracker 17 and I had to make several adjustments before I could get it to work. I have it mounted on the left side. The transducer needs to set just below the hull.

    Comment


    • #3
      If you have the transducer installed correctly, check the hull bottom that is forward of the location for dents or some other "thing" that can aerate the water that passes over the transducer.

      Comment

      Working...
      X